IndiFTPD is a standalone (single executable) FTP server with many advanced features (including SSL).  It is written in C++ and supports Windows, Linux, Solaris, and FreeBSD.  IndiFTPD is designed around a core server which can be easily extended.






IndiFTPD is a standalone (single executable) FTP server designed for situations when a user wants to quickly start up a server without going through an installation.  It contains the essential FTP features as well as many advanced features and configuration options.  IndiFTPD is completely self contained  and does not require any configuration files or supporting binaries (on Windows the C runtime dll, for example msvcrt40.dll, might be needed).  It is currently designed to support the Windows, Linux, Solaris, and FreeBSD operating systems.

Some of the key features of IndiFTPD are:
- Implements FTP as specified in RFC 959 as well as some additional features described in RFC 2389 and RFC 2577
- Explicit (AUTH SSL) and implicit SSL support
- Resumable downloads and uploads
- Customizable user permissions
- Customizable logging
- Configurable passive port ranges for use with firewalls

The IndiFTPD code is partitioned into two primary pieces: the server core, and the specific server implementation.  The core contains all the code for a basic FTP server.  The only file that must be added to make the core a functional server is an implementation of the main() function.  A a minimal implementation of the server core, called BasicFTPD, is included with the IndiFTPD source code.  BasicFTPD provides a starting point for creating a new server based on the core code.  IndiFTPD is also designed to be easily extended by simply adding new methods to override the default FTP command implementations.

To build IndiFTP in Windows project files for both 'Microsoft Visual Studio .NET 2003' and 'Microsoft Visual C++ 6.0' are provided.  To build IndiFTPD on a UNIX system (Ex. Linux) a Makefile is provided.  To enable SSL OpenSSL version 0.9.6 will also be needed (this can be downloaded from www.openssl.org).

For more information visit http://www.dftpd.com
